It is currently Wed Oct 23, 2019 11:23 pm


Post a new topicPost a reply Page 1 of 1   [ 1 post ]
Author Message
 Post subject: DC40 low suction in base, intermittent power issues
PostPosted: Sat Oct 05, 2019 11:22 am 

Joined: Sat Oct 05, 2019 11:17 am
Posts: 1
Dyson model: DC40
Hiya

I bought a Dyson DC40 second hand and it clearly has some problems. I can't return it so I'm trying to repair it myself.

I have already thoroughly cleaned everything: both filters, every single separate piece, hoses etc. There are no visible blockages or dust.

At times the Dyson turns on and I'm able to use the hose perfectly, but never the base. At other times it just will not switch on at all.

I have noticed that the rubber seal connecting the body of the vac to the bin, is not sealing well. I can't find spares of it online.

Would love some advice please :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 1 post ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron



The Unofficial Dyson Forum is in no way affiliated with Dyson Ltd.
NO SEO MAIL PLEASE : admin@dysonforum.com
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
twilightBB Style by Daniel St. Jules of Gamexe.net