It is currently Tue Feb 19, 2019 7:02 am


Post a new topicPost a reply Page 1 of 1   [ 1 post ]
Author Message
 Post subject: DC65 - was used to vacuum water, now no voltage to head
PostPosted: Sat Jan 19, 2019 3:35 am 

Joined: Sat Jan 19, 2019 3:30 am
Posts: 1
Dyson model: DC65 Plus
Look, it wasn't me! lol

Some one borrowed my DC65 and used it to vacuum water. I thought at first the head motor was shorted, but that seems to still spin when power is applied to it when removed. I tested the vacuum with a multimeter and there's no voltage coming out of the head attachment port at all.

So, what could have failed? The brush head switch seems far from the water (but who knows what was done to the vac). There is some kind of switch inside the vac that turns off power when upright. There's also got to be some kind of transformer.

Any thoughts where to look next?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 1 post ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron



The Unofficial Dyson Forum is in no way affiliated with Dyson Ltd.
NO SEO MAIL PLEASE : admin@dysonforum.com
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
twilightBB Style by Daniel St. Jules of Gamexe.net